/   \
  Home   Jörg Sigle's  Quality-of-Life-Recorder  featuring  AnyQuest  for Windows    
  Home    
  Home   / Introduction \ / Software \ / Questionnaires \ // Docs+Support \\ / Service \    
 
    / \  
 
Deutsche Version   


Documentation+Support  

Help   

Various documents   
   Short summaries   
   Manuals, examples   
   Videos   
   Scientific material   
   Book contributions   
   Awards   
   Other information   

Data export to SAS or SPSS • 

 

How to transfer data from AnyQuest to SAS Statistical Analysis Software (or to SPSS) and how to perform simple data analysis using SAS

These instructions were originally written on 2003-07-31 by Jörg Sigle using AnyQuest version 2.62 and SAS version 8e for Windows.

This is a preliminary version of these instructions. A revised and enhanced version, a German version and versions for AnyQuest to SPSS, and AnyQuest to Xplore, AnyQuest to Excel, AnyQuest to Access may follow soon. Please note that the "extract" utility is currently available upon request, but may be published in the AnyQuest software archive as well. js 2003-10-31 08:20

These instructions were briefly revised on 2008-03-28 by Jörg Sigle using AnyQuest version 3.16. Especially, on-the-fly recoding of symbols for missing values has facilitated data transfer to SAS and SPSS.

Please note that data export for SPSS is the same as data export for SAS. Files have been exported from AnyQuest for Windows and imported into SPSS completely without any intermediate processing.


The instructions look lengthy, because they are very detailed. The process is very simple and transporting a data set from AnyQuest to SAS can actually be completed in less than 5 minutes.

Other guides on the same topic are available in AnyQuest for Windows' fully indexed and searchable on-line help, as well as in the "Printout interpretation, data analysis and data export guide" ("Anleitung zur Interpretation von Ausdrucken, zur Datenanalyse und zum Datenexport") from the eSIRO project available on the "Documents and Tutorials" page of the AnyQuest for Windows WWW site.


These instructions explain the following steps:


Prerequisites / Options

In order to export data collected with AnyQuest for Windows, you need:

  • Collected data in the form of multiple *.anq files as produced by AnyQuest for Windows. You can collect data on one system, transfer collected files to another, and perform data analysis and export there. You can also use mapped network drives in the process.
  • An installed version of AnyQuest for Windows on the system where you want to perform the data export. Any version of AnyQuest for Windows should be able to process any *.anq file produced with any version of AnyQuest for DOS or AnyQuest for Windows.

Specifically, you do not need any questionnaire definition files *.qdw to perform a general data export - the result files contain all necessary information in themselves.

In order to import and postprocess data from AnyQuest for Windows, you may use software like SAS, SPSS, Spida, Xplore, Microsoft Excel, Microsoft Access, OpenOffice, StarOffice and so on.

As an alternative to individually performed data exports, an AnyQuest Server as a backend to collect data from multiple sites and provide automatic and on-demand on-line analyses as well as a live repository that can be queried by analysis software like SAS or SPSS is also available upon request.

For simple analyses (like interactive data selection based upon freely definable conditions, general statistics, box plots, course over time plots for individual patients or for whole groups), AnyQuest for Windows has built in functionality. Additionally, you can generate separate data export files for pre-selected data. Finally, a configurable data extraction utility is available that can be used to repeatedly and/or automatically transfer pre-definable data fields into tabular output files. None of these techniques are described in this document, but you may refer to AnyQuest's on-line help, to the AnyQuest for DOS manual (for the extraction utility) or to other documents on the "Documents and Tutorials" page of the AnyQuest for Windows WWW site.


Data export from AnyQuest

  • Start AnyQuest for Windows from the Start menu
  • In the AnyQuest Navigation window: click the "Setup" button
  • Optional: ensure that the data directory is set correctly: From the menu, select: "File" - "Data folder setup"
    The standard data folder is c:\anyquin\data, but this might vary depending upon your own configuration. If in doubt, ask the person who configured your system.
  • From the menu, select: "File" - "Generate data export file from multiple *.anq output files"
  • In the data export dialog, please change the name and a variety of format options according to your requirements. The default format settings are mostly appropriate for target applications like SAS, SPSS or Microsoft Excel and for clinical users of questionnaires, but some depend upon your MS Windows environment, so you should review them. You should definitely review and adopt the output filename extension:
    • Export file name:
      The default filename is anyquin.dif - because MS Excel, years ago, was usually associated with this file type and would conveniently import such a file when it was double-clicked. Nowadays, however, the QuickTime player may have taken it - and Excel's import may not work as desired if you just start it by double clicking. So if you want to transfer data into MS Excel today, it is recommended to change the filename to anyquin.dat. For data export towards SAS, or SPSS, please change the filename to anyquin.txt
    • Decimal separator:
      For data transfer to SAS, set this to a full stop (.), and do not use the comma. The default and your preferences may depend upon your Windows system environment - in Germany, it is a comma. However, this setting also affects exported raw data in scientific format. SAS prefers a dot here, supplying a comma would lead to errouneously large numbers interpreted the wrong way (if scientific format is not suppressed at all, as can be chosen further down).
    • Column delimiter:
      The default is a Tabstop and this works for SAS and most other target programs.
    • Include...
      These options determine which sections of the collected data files are actually transferred into your data export file:
      • ...session log:
        This section is only useful, if you activated the production of session logs during data collection. The session log may report detailed information about when sessions where started, interrupted, resumed, and whether any comments were recorded at each of these events. Export table columns are only generated for this section, if appropriate information is available at all.
      • ...language and version:
        This section includes information about which language and which version of a questionnaire were used to collect a data set. It is especially helpful if you analyse data from various languages or versions.
      • ...other meta information:
        This section refers to information about the numbers of questions, result dimensions, and minimum and maximum values of each result dimension. It is normally not needed for statistical data analysis: In most cases, you should usually know these characteristics for the questionnaire you have used, and don't want to read this information next to each exported data set data.
      • ...raw data:
        This section is probably important if you construct or validate questionnaires. It is probably less important, if you are a user of an already completely developed and validated questionnaire.
      • ...computed results:
        This section contains computed numeric questionnaire results. This is the main information that would be analysed in a typical clinical study.
      • ...computed string results:
        If the questionnaire delivers string (text) results in addition to numeric results, you will find them here. This section may also contain additional information for undefined numeric results.
      • ...additional text information:
        This section may contain information if a patient could not answer or did not want to answer an individual question, and has supplied details about the reason for this. It also contains anything typed into any free text collection fields you may have used in your questionnaire. Export table columns are only generated for this section, if appropriate information is available at all.
    • Recode [---] to [.], [--- ¬can] to [.], [--- ¬want] to [.]:
      This on the fly recoding function should be active if you want to transfer data to SAS or SPSS. AnyQuest has three different standard representations for missing data, which encode generally unavailable data: ---, or data unavailable because a patient said she could not answer a certain question: --- ¬can, or data unavailable because a patient said she would not want to answer a certain question: --- ¬want. SAS and SPSS, in contrast, simply use a dot: . to represent a missing datum. When they try to import a data export file from AnyQuest which contains the detailed missing data symbols used by AnyQuest, they may conclude that the whole column in which they find such thing be a string column instead of a column with numeric data. This would not be all that bad by itself - but they won't want to perform any calculations on string columns, but prefer to use them for classification instead. With older versions of AnyQuests, the steps shown in the "obsolete" section below were required to overcome this. Modern versions of AnyQuest can perform the replacement on the fly. If you have other target applications with other requirements, you may of change the target value as desired. Be careful if you consider using an asterisk: *, though: in MS Excel this may be a wildcard for anything, and replacing an asterisk with anything alse may render a whole table with very similar entries. In an SQL database, a percent sign: % is typically a wildcard and should thus probably be avoided as well.
    • Enforce format for numerical output:
      You may probably prefer to activate this option and make AnyQuest output everything in "fixed format with 3 digits after the decimal point" or in a similar way. If this option is inactive (or if you use an older version that did not have this option), AnyQuest will probably export raw data in scientific notation with all available precision, and computed test results in a format depending upon the used questionnaire definition file. What you will see in your target application (SAS, SPSS, Excel etc.) will of course ultimately depend on that target application itself, and numbers can be brought into any desired format in these programs as well. But not all users know how to do this, and engineers are probably less disturbed by numbers in "scientific format" (like 2.718281828459045091+E0001 instead of 27.2) than social scientists are, and even Excel may get a string hickup when trying to import them with the wrong decimal separator... so this option is available for your convenience.
  • As soon as you have chosen the options you like, click OK and wait until the software confirms that the data export file has been generated. AnyQuest will indeed scan all *.anq files found in the data directory in a first pass, and will automatically generate a sorted table with all needed columns to accomodate for all questionnaires used in any of these data files, and fill this table with data in a second pass. Thus, you do not need to know the details about the content of the *.anq files when you use this data export function.
  • If you did not specify an alternative path, the generated data export file will be placed into your data directory, just where your *.anq files were located. If you followed the instructions given above and work in an unmodified default environment, its complete filename should be: c:\anyquin\data\anyquin.txt
  • Finally, you may close AnyQuest for Windows.
  • As an alternative to the global unselected data export function from the "File" - Menu, you can use AnyQuest's built in "Analysis tools" to first select one or more groups of result files into file lists, and then automatically perform a data export for each file list into a separate data export file. This procedure is described in AnyQuest's on-line help for its built in Analysis Tools and it may be the more useful, the less familiar you are with data selection and -reorganization capabilities of your target application.
  • As an alternative to the interactive data export functions built into AnyQuest for Windows, there is also a separate utility extract.exe available upon request, which can be configured to produce a defined output table from available *.anq files. This utility lets you select individual entries from *.anq files and define the column names and the sort order of the resulting table and can also be called from a batch job or run unattended. This utility is especially useful if you want to select certain known columns for data transfer, and do not want the columns included in the output file to vary even if *.anq files generated by using other questionnaire definition files, or generated with other patient ID data collected, or transporting other additional text information or session log information, are added to your data pool.
  • As an alternative, AnyQuest Server is available which can continuously store incoming *.anq files from multiple data contributors, and either perform analyses by its own or work as a live database repository that can be directly contacted with tools like SAS and SPSS on the fly to generate advanced statistical analyses.

Export data file modification (rather obsolete)

Depending upon your data contents and upon your desired analysis steps, some modifications must be carried out on the data export file to be able to import it smoothly into SAS using the data import wizard.

As this implies a few manual editing steps, this way is only recommended for occasional data transfer.

Should you require regular data transfers from AnyQuest into SAS, you may prefer to use the SAS EFI functionality to define a user specific data import scheme specifically declaring the properties of each data column to be imported, instead of preparing the AnyQuest data export file for proper import with the SAS data import wizard. The next section also explains how to start EFI.

Changing missing data indicators (rather obsolete)

(This is rather obsolete, as modern versions of AnyQuest for Windows support on-the-fly recoding of missing data indicators during data export - see above.)

If your export data contains missing values, AnyQuest (in its default setting) exports these as three dashes ("---"), which in the raw data section can be followed by a more detailed explanation ("¬Can" or "¬Want").

SAS, instead, by default recognizes a blank (space) or a full stop as a missing value. If either of AnyQuest's missing value indicators occurs in any single field, SAS' automatic import wizard treats this column as a text/character column.

To overcome this problem:

  • Open your data export file (if you followed the instructions above, by default: c:\anyquin\data\anyquin.txt) using an editor (e.g. MS Windows Notepad (NT and above, 9x notepad cannot handle large files and does not offer search/replace functionality), MS Windows Wordpad, PSPad, TextPad, UltraEdit, MS Word, StarOffice, MS Excel...).
  • If the display is confusing and you use MS Windows Notepad: turn line-wrapping of ("Edit" - "Line wrapping/Zeilenumbruch").
  • Replace each AnyQuest for Windows missing value indicator by a simple full stop:
    old (search)new (replace by)
    --- ¬Can .
    --- ¬Want .
    --- .
  • Save the file again. If you use advanced text editors like MS Wordpad or MS Word, be sure to save in plain text format (without any additional document or formatting information), if you use a spreadsheet like Excel, be sure to maintain the simple tab-stop separated list format.

Removing lines with comments and units (may or may not be obsolete - depending upon the behaviour of your SAS version)

(Theoretically, both SAS and SPSS can be instructed to ignore a number of initial lines after the headings line while a data table is being imported. But even when told to ignore additional headings lines, some SAS versions may evaluate them for automatic format analysis, and draw wrong conclusions - ssee below.)

In the first lines of the data export file, AnyQuest supplies:
Line 1:column headings
Line 2:empty
Line 3:comments / units
Line 4:empty
Line 5 ff.:data (1 questionnaire session = 1 *.anq file per line)

When SAS imports such a file, it finds comments or units in line 2, e.g.: "years" or "(only valid if...)". Because these things look very text-like, SAS concludes that each column containing such a comment, is a text (character) column, and not a numeric data column. And as it prefers to use text/character columns for classification and numeric columns for analysis, it will not be able to perform analyses like a box plot of the computed age of patients in this configuration.

CAVE: This unwanted interpretation may happen in some versions of SAS even when you instruct SAS to ignore the additional heading lines.

To overcome this problem:

  • Open your data export file (if you followed the instructions above, by default: c:\anyquin\data\anyquin.txt) using an editor (e.g. MS Windows Notepad (NT and above, 9x notepad cannot handle large files), MS Windows Wordpad, PSPad, TextPad, UltraEdit, MS Word, StarOffice, MS Excel...).
  • If the display is confusing and you use MS Windows Notepad: turn line-wrapping of ("Edit" - "Line wrapping/Zeilenumbruch").
  • Remove line 2 (empty), line 3 (containing a variable number of units/comments) and line 4 (empty), so that SAS will not get confused by this text content.
  • Save the file again. If you use advanced text editors like MS Wordpad or MS Word, be sure to save in plain text format (without any additional document or formatting information), if you use a spreadsheet like Excel, be sure to maintain the simple tab-stop separated list format.

Data import into SAS

  • Start SAS
  • From the menu, select: File - Import data...
  • In the Import Wizard...
  • Ensure that "Standard data source" is checked.
    (If you require regular data transfers from AnyQuest into SAS, and you want to avoid the manual editing steps described above, you can alternatively switch over to using the SAS EFI instead of the standard data sources. EFI lets you define exactly which source file column SAS shall import into which target table column in which format, but it needs some preparation and is probably best used when you have seen and understood the results and the limitations of the automatic standard import wizard.)
  • From the list of data sources, select "Tab delimited file (*.txt)"
  • Click "Next"
  • In the field below "Where is the file located?", enter the complete name of the data export file you generated in AnyQuest. You may also use the "Browse" to locate the file on your hard-disk or in your network. If you did not change the data path in AnyQuest, and generated the export file exactly as suggested above, the complete filename of the data export file should be: c:\anyquin\data\anyquin.txt
  • If you did not remove lines 2, 3, and 4 as mentioned in the paragraph "Export file modification" above:
    • Click "Options"
    • In the field next to "First row of data:", enter 5
    (This tells SAS that rows 2, 3, 4 shall not appear in the result table because AnyQuest uses the first row to supply the column names, the third row for optional units or comments, and rows two and for as empty separator rows. But even (!) if you ask SAS to skip rows 2, 3, 4 here, any text entries found in any column of these rows will still make SAS treat the respective column as text/character column instead of numeric column (at least this happened in version 8 used for the original writing of this guide), and thus make it unusable for analysis purposes.)
  • Ensure that "Get variable names from first row." is checked.
  • In the Delimited File Options dialog, click "OK"
  • In the Import Wizard dialog, click "Next"
  • For experienced SAS users: If you wish, select another target library than "WORK". Otherwise, just leave the default setting.
  • In the field below "Member", write the name of the new table which SAS will generate from the imported data. An example: "qldata"
  • In the Import Wizard dialog, click "Next"
  • For experienced SAS users: If you want to create a file with all statements needed to later do a similar import in SAS, you may specify a filename for this now.
  • In the Import Wizard dialog, click "Finish"
  • SAS will now import AnyQuest's data export file and generate a new table containing your data.
  • You should review the SAS log to learn about the details of the automatically created SAS import commands, and their results. Please pay special attention to the data format used for each line: best32. or best12. or may indicate that data has been interpreted as numerical data whereas $, or $29 or something alike may indicate that data has been interpreted as text/character/string data.
  • Column headings in the resulting SAS table will be derived from the AnyQuest data export file. If you did use the built in export tool from AnyQuest for Windows, these column headings will match the result dimension names found in the exported *.anq files, and they in turn will be the result formula file output labels specified during definition of the *.qdw (questionnaire definition file) used to collect the data. Very long column names may be truncated to a length supported by SAS. If you want to have other column headings, you can either redefine column headings in SAS (this is possible either manually or using an SAS program), or you can use the AnyQuest utility extract.exe to generate your data export file from *.anq files. This utility uses a data extraction configuration file where you can specify the column headings exactly to your needs.
  • AnyQuest for Windows 2.62 apparently exports an excess tab after the last column in each line, so SAS imports a final, completely empty column. AnyQuest apparently also exports an excess character (#0 or something similar) after each source filename in the respective column, so if you import an export file without passing it through a tool that ignores and/or removes it, a representation of this extra character may be visible in your resulting SAS table. These flaws should not really affect your work, but they are not beautiful and I will look into this later and probably change AnyQuest's behaviour, if it does not have any proper reason. [Note: as of AnyQuest version 3.16, the extra tab (causing an empty field) at the end of each line is still there, whereas the unwanted #0 after the filename, which specifically disturbed SPSS, was removed. - See product history in AnyQuest's on-line help for detailed information.]

Simple data analysis examples using SAS

These examples assume that you collected data in AnyQuest using a QLQ-C30 Version 3.0 questionnaire defintion file, and transported collected data into SAS following the above instructions.

Viewing imported data

  • In the SAS Explorer window, double-click on "Libraries"
  • In the SAS Explorer window, double-click on "Work"
  • In the SAS Explorer window, double-click on "Qldata" - a view on a table appears, showing your quality-of-life data. You can navigate within this table using the mouse and the scroll bars.

Simple SAS programs

To use one of these programs: copy them and paste them into the SAS program editor. Execute the program by pressing [F8].

Of course, you can combine multiple code snippets and save them in your editor to perform the analysis of your choice automatically.

Import a data file

This is the transcript which the Import Wizard actually generates from all your mouse-clicks suggested above:

proc import
OUT=WORK.qldata
DATAFILE="c:\anyquin\data\anyquin.txt"
DBMS=TAB REPLACE;
GETNAMES=YES;
DATAROW=2;
run;

Simple summary statistics

proc tabulate data=work.qldata ;
var COMPUTED_AGE C30V3_PHYSICAL_FUNCTION C30V3_NEW_ROLE_FUNCTION
C30V3_EMOTIONAL_FUNCTION C30V3_COGNITIVE_FUNCTION C30V3_SOCIAL_FUNCTION
C30V3_NEW_GLOBAL_HEALTH_QUALITY C30V3_FATIGUE C30V3_NAUSEA_AND_VOMITING
C30V3_PAIN C30V3_DYSPNEA C30V3_SLEEP_DISTURBANCE C30V3_APPETITE_LOSS
C30V3_CONSTIPATION C30V3_DIARRHEA C30V3_FINANCIAL_IMPACT;
table
computed_age
C30V3_Physical_function
C30V3_New_role_function
C30V3_Emotional_function
C30V3_Cognitive_function
C30V3_Social_function
C30V3_New_global_health_Quality
C30V3_Fatigue
C30V3_Nausea_and_vomiting
C30V3_Pain
C30V3_Dyspnea
C30V3_Sleep_disturbance
C30V3_Appetite_loss
C30V3_Constipation
C30V3_Diarrhea
C30V3_Financial_Impact
,
(
'N'='Number of nonmissing values'
'MIN'='Minimum value'
'MEDIAN'='Median'
'MAX'='Maximum value'
)
;
run;

A simple box plot, and creating additional columns

SAS wants a group variable for its box-plots. For convenience, this program uses AQ_LICENSE for this purpose. This could also be used to compare QL results from various sites conveniently e.g. for benchmarking purposes (n.b.: "benchmarking" is not necessarily bad. If you finde differences using this technique, you can discuss their causes and maybe identify options for improvement).

proc boxplot data=qldata;
plot (
COMPUTED_AGE
C30V3_PHYSICAL_FUNCTION
C30V3_NEW_ROLE_FUNCTION
C30V3_EMOTIONAL_FUNCTION
C30V3_COGNITIVE_FUNCTION
C30V3_SOCIAL_FUNCTION
C30V3_NEW_GLOBAL_HEALTH_QUALITY
C30V3_FATIGUE
C30V3_NAUSEA_AND_VOMITING
C30V3_PAIN
C30V3_DYSPNEA
C30V3_SLEEP_DISTURBANCE
C30V3_APPETITE_LOSS
C30V3_CONSTIPATION
C30V3_DIARRHEA
C30V3_FINANCIAL_IMPACT
)*AQ_LICENSE_1;
run;

This program shows how you can temporarily create a table adding a new column with a hand-made group variable, should you need it, e.g. to call the plot function.

Should you want to modify some graphics options, please consult the SAS documentation for details.

/* create a new view on table qldata
named table _tmp_1
adding a column _dummy_ to the existing table qldata,
so that box-plot procedure can use _dummy_ as grouping variable
to put all rows into a single group */

proc sql;
create view WORK._TMP_1 as
select *,1 as _dummy_
from work.qldata;

/* now create the boxplot from table-view _tmp_1 */

proc boxplot data=_tmp_1;
plot (
COMPUTED_AGE
C30V3_PHYSICAL_FUNCTION
C30V3_NEW_ROLE_FUNCTION
C30V3_EMOTIONAL_FUNCTION
C30V3_COGNITIVE_FUNCTION
C30V3_SOCIAL_FUNCTION
C30V3_NEW_GLOBAL_HEALTH_QUALITY
C30V3_FATIGUE
C30V3_NAUSEA_AND_VOMITING
C30V3_PAIN
C30V3_DYSPNEA
C30V3_SLEEP_DISTURBANCE
C30V3_APPETITE_LOSS
C30V3_CONSTIPATION
C30V3_DIARRHEA
C30V3_FINANCIAL_IMPACT
)*_dummy_;

/* finally remove table-view _tmp_1 */

proc datasets lib=work nolist;
delete _TMP_1 /memtype=view;
run;

I'm afraid that SAS produces a single plot for every dimension instead of combining all of them into a single program. Its box plot routine appears to put measurements with different group variables into different boxes combined in a single diagram - this is not what I'd prefer to print QL-profile box plots, but with my minimal SAS knowledge I cannot persuade SAS to do it differently. Probably, it can be achieved by re-arranging data from the tables (probably some rotation) but I'm not in the mood to figure that out now.

Using the SAS Analyst with imported data

The "Analyst" is one of the SAS solutions which allow you to analyze your data interactively, using dialogs and the mouse, without the need to type programs. Actually, the Analyst generates the programs while you select algorithms and variables, you can copy the resulting programs from the SAS log and modify and re-use them later.

  • From the SAS menu, select "Solutions" - "Analysis" - "Analyst". The analyst dialog appears, the SAS menu changes and becomes the Analyst menu.
  • From the Analyst menu, select "Open by SAS name". Double-click on "work" and then double-click on "Qldata". The contents of qldata appear in the table-section of the Analyst window.
The simple box plot, only
  • From the Analyst menu, select "Graphs" - "Box Plot"
  • In the Box Plot dialog, first select and mark "computed_age" entry in the left list, and then click on the "Analysis" button to select this column of your table into the Analysis variables selection (this only works, if computed_age has been correctly recognized as a numeric variable by the import wizard, as explained above).
  • Additionally, select and mark all entries from "C30V3_Physical_Function" to "C30V3_Financial_Impact" (marking multiple entries: mark the first one, hold down the [shift] (upper-case) button on your keyboard while marking the last one).
  • Finally, click on "OK".
Impressive simple statistics, including a simple histogram

The following tool gives you most basic descriptive analyses, whether or not they are meaningful for you:

  • From the Analyst menu, select "Statistics" - "Descriptive" - "Distributions"
  • In the Distributions dialog, first select and mark "computed_age" entry in the left list, and then click on the "Analysis" button to select this column of your table into the Analysis variables selection (this only works, if computed_age has been correctly recognized as a numeric variable by the import wizard, as explained above).
  • Additionally, select and mark all entries from "C30V3_Physical_Function" to "C30V3_Financial_Impact" (marking multiple entries: mark the first one, hold down the [shift] (upper-case) button on your keyboard while marking the last one).
  • Finally, click on "OK".
  • If you like plots, click the respective button and select the one(s) you wish to get.

(If something is too much to understand and obviously related to mathematics, there might be a chance that it is received as impressive.)

Simple statistics and correlations, including nice correlation plots with confidence ellipses

How is the patients' age correlated with their reported subjective QoL?

  • From the Analyst menu, select "Statistics" - "Descriptive" - "Correlation"
  • In the Correlation dialog, first select and mark "computed_age" entry in the left list, and then click on the "Analysis" button to select this column of your table into the Analysis variables selection (this only works, if computed_age has been correctly recognized as a numeric variable by the import wizard, as explained above).
  • Additionally, select and mark all entries from "C30V3_Physical_Function" to "C30V3_Financial_Impact" (marking multiple entries: mark the first one, hold down the [shift] (upper-case) button on your keyboard while marking the last one).
  • Select the algorithm you want to use from "Options" - Pearsons (parametric) is used most often, but I feel that Spearman's (non-parametric) is more justified for QL data. Although the QLQ-C30 delivers results on a linear scale from 0 to 100, and its individual answers are scored 1 to 7 in a linear way: The answers which patients may chose from are anchored to text primarily, not numbers, and is anyone sure that the distance between "not at all" and "a little" is the same as between "quite a bit" and "very much"? If you wish, you can advise SAS to print descriptive statistics as well. When you read about mean, standard deviation versus median and quartiles, please re-consider my remarks about what kind of measures are more often used and what kind of measures might be more appropriate.
  • If you like, select something you like from "Plots".
  • Finally, click on "OK".

Please note that the focus of the above examples lies on descriptive methods. I may be wrong, but I guess that statistical tests should rather be used after one has formulated a clear hypothesis, and this in turn should be done after a some experience in using descriptive measures with data from one's own area has been collected.


A note about bringing data from various sources together

Both SAS and SPSS have the capability to join data from multiple sources (or tables) on some common field in order to perform a combined analysis. This may be helpful if you want to analyse data from questionnaires collected with AnyQuest for Windows together with data collected in other ways, e.g. in an Excel table or via SAS' or SPSS' built in data input tables.

Both SAS and SPSS have the capability to provide views (or tables) with temporarily selected subsets (selected by columns, or by rows, even from multiple source tables) of your data.

Please consult your SAS or SPSS documentation on how to carry out such tasks. If you have no experienced user at your site, I may be able to assist upon individual request.

A note about analyzing data from repeated measurements in the same patient

If you perform a global export of unselected data within AnyQuest for Windows, data from multiple measurements in the same patient with the same questionnaire (or set/battery of questionnaires) will typically appear in multiple lines within one table.

It is possible in AnyQuest to activate patient ID fields named group, subgroup, cycle, subcycle, rater, assessment etc. to collect one or more individual identifiers of each individual measurement, but these options must be activated before measurement begins, and the fields must properly be filled in during all measurements. By design, AnyQuest does not automatically fill in these fields with incrementing numbers, because increments above one might be correct e.g. when a patient misses an assigned questionnaire administration for a given therapy cycle, or when data are collected on technically separate systems for different therapy/measurement cycles. It is however, also possible, to use MS Excel or SAS scripts to generate a column and automatically fill it in with ascending values for subsequent measurements after sorting by patient ID and date/time of test.

Both SAS and SPSS can be used to perform multidimensional analysis, where the patient, the number of measurement, and the result are taken into account.

If a low number of measurements per patient has been performed, some researchers may prefer to have only one row for each patient, and corresponding results (like: physical function at first measurement PF1, and physical function at second measurement PF2) appear in different columns of the same row.

If you need to carry out a data reorganization like this, and have no experienced user at your site, I may also be able to assist upon individual request.


   
    \ /  
     
      © 1996-2012 by  Dr. med. Jörg M. Sigle -» Sitemap      Contact - Imprint WoopieLogo1  
\   WoopieLogo2 /